What are the prerequisites for extracting HANA data?

The following prerequisite must be met before extracting your custom code and uploading it to Panaya's Code Box.
This is an SAP requirement for HANA, regardless of your SAP HANA migration project in Panaya.

  • Please make sure that the code inspector has the 'HANA check variants'.
    For more details, please follow note: 1912445 - ABAP custom code migration for SAP HANA - recommendations and Code Inspector variants for SAP HANA migration.
     
  • In order to implement note 1912445 and perform the HANA analysis, your SAP NetWeaver Product version and SP must be at least one of the following - 
    SAP NetWeaver 7.02 as of SAP_BASIS SP14
    SAP NetWeaver 7.31 as of SAP_BASIS SP09
    SAP NetWeaver 7.40 as of SAP_BASIS SP02
     
  • If the system is not on one of the above mentioned NetWeaver product versions and SP levels, you must either upgrade it OR run the Hana Code Inspector on a different system

Note
In most cases where the system version is higher than mentioned in note 1912445, variants are already enabled